Rainbow - [EMEA] Rainbow Hub : Service degradation – Incident details

System Under Maintenance

[EMEA] Rainbow Hub : Service degradation

Identified
Degraded performance
Started 15 days ago

Affected

Europe & Middle East (EMEA)

Degraded performance from 6:00 AM to 12:00 AM

[EMEA] Rainbow Hub Voice Services

Degraded performance from 6:00 AM to 12:00 AM

Updates
  • Update
    Update

    Our investigation has identified a workaround that addresses the latency experienced on incoming calls as well as incoming call disconnections. The workaround is currently being prepared for deployment and is expected to be fully applied by tomorrow at the latest.

    Regarding the poor audio quality previously reported by some customers, a corrective change was implemented last Friday. Based on our monitoring and validation, this issue should no longer be occurring.

    We remain focused on validating the effectiveness of these measures and will continue to share meaningful updates as progress is made.

  • Update
    Update

    Our investigation indicates that this degradation may be related to previously reported issues over the last two weeks.

  • Identified
    Identified

    Our technical teams have identified the likely cause of the service degradation. We have experienced an unusual surge in customer traffic across the EMEA region, resulting in significantly higher demand on the infrastructure supporting call queues and auto attendants.

    The impact is primarily observed during specific periods of the day when traffic reaches peak levels. Outside of these peak periods, service performance remains within expected levels.

    We are actively working to implement additional scaling measures and infrastructure optimizations to further strengthen service performance and resilience.

    Our teams continue to closely monitor the situation and are making progress on the capacity expansion plan. We will provide further updates as additional information becomes available.

    Thank you for your patience and understanding.

  • Investigating
    Investigating

    On July 06, 2026 at 11:15:54 AM:

    Some customers are experiencing degraded performance, including call disconnections, poor audio quality, and increased latency when establishing or receiving calls.

    Our technical teams are actively investigating the issue to determine the root cause and assess the full scope of the impact.

    We will provide further updates as soon as more information becomes available.

    Thank you for your patience and understanding.