Rainbow - [EU] Rainbow Hub - Interruption of Telephony service – Incident details

All systems operational

[EU] Rainbow Hub - Interruption of Telephony service

Resolved
Operational
Started 7 days agoLasted 20 minutes

Affected

Europe & Middle East (EMEA)

Major outage from 9:15 AM to 9:32 AM, Degraded performance from 9:32 AM to 9:35 AM

[EMEA] Rainbow Hub Voice Services

Major outage from 9:15 AM to 9:32 AM, Degraded performance from 9:32 AM to 9:35 AM

Updates
  • Postmortem
    Postmortem

    Post-Incident Report

    Incident Window: June 2, 2026 - 11:09 – 11:30 CEST

    What happened?

    Yesterday, we experienced a temporary issue affecting one component of our Rainbow Hub infrastructure. A switchover to the backup system was automatically triggered, but it did not start as expected, which led to a short service disruption.

    Impact

    During this period, Rainbow Hub users in Europe were unable to make calls.

    Resolution

    Our teams acted immediately to stabilize the affected system and safely restore service. Full service was restored at 11:30 CEST.

    Root cause

    The issue was linked to an internal database system inconsistency that impacted service availability and prevented the failover mechanism from operating as expected. This type of inconsistency had been observed previously, but only under a very specific and rarely encountered combination of conditions. A correction addressing this class of issue was already in preparation and planned for production update.

    What we’re doing?

    The fix addressing this issue will be deployed on our European infrastructure on the evening of June 3rd, as part of a more general worldwide fix in all regions. While we have strong confidence this will prevent a recurrence, we are continuing to monitor closely.

    We sincerely apologize for the inconvenience caused and thank you for your patience and continued trust.

  • Resolved
    Resolved

    This incident has been resolved.
    If you continue to experience issues, please restart your Rainbow phone or softphone application.
    Thank you for your patience and understanding throughout this incident.

  • Monitoring
    Monitoring

    Service restoration in progress
    Services are currently being restored. Please note that it may take some time before full service is fully restored for all customers. Our teams remain fully engaged to complete the recovery as quickly as possible.

  • Identified
    Identified

    Our teams have identified the origin of the incident. Mitigation actions are in progress, including cleanup and restart of the impacted component. Service recovery is underway, and we will continue to keep you informed.

  • Investigating
    Investigating

    Some customers have reported issues on Rainbow Hub. 
    Our technical teams are analyzing the issue to identify the root cause and assess the full impact.
    We will provide an update shortly.